Search found 15 matches

by sparkzara
Fri Nov 04, 2022 4:17 pm
Forum: General discussion
Topic: Nginx get domainname without TLD or suffix
Replies: 2
Views: 89

Re: Nginx get domainname without TLD or suffix

hi, thanks for the reply. but i wanted this to be applied for all the domain added on myvestacp using a specific template. Note: i'm doing domain addition through api. but here is the list of things i did so far. created 2 files on /usr/local/vesta/data/templates/web/nginx/ 1. reverse-force-https.tp...
by sparkzara
Thu Oct 27, 2022 9:47 pm
Forum: General discussion
Topic: Nginx get domainname without TLD or suffix
Replies: 2
Views: 89

Nginx get domainname without TLD or suffix

Hi, I am trying to add reverse proxy template to show content from a subdomain based on domainname. For ex: example.com should show content from example.maindomain.com I tried to use %domain%, but it gets full name including TLD value like example.com.maindomain.com Is there any nginx variable or co...
by sparkzara
Sun Sep 18, 2022 1:47 pm
Forum: API
Topic: Why API is not working?
Replies: 2
Views: 4803

Re: Why API is not working?

hi, i tried above steps. but it doesn't seem to be working. and regarding error: I get empty response, so not sure where exactly the error is. Code used: $vst_hostname = env('VESTA_HOSTNAME'); $vst_username = env('VESTA_USERNAME'); $vst_password = env('VESTA_PASSWORD'); $vst_returncode = 'yes'; $vst...
by sparkzara
Wed Mar 30, 2022 11:51 am
Forum: General discussion
Topic: Installing PHP-FPM 8.1 on debian server
Replies: 3
Views: 1089

Re: Installing PHP-FPM 8.1 on debian server

myVesta wrote: Wed Mar 30, 2022 10:49 am viewtopic.php?f=18&t=52
Thank you, script works fine and enabled php 8.1 now
by sparkzara
Tue Mar 29, 2022 4:55 pm
Forum: General discussion
Topic: Installing PHP-FPM 8.1 on debian server
Replies: 3
Views: 1089

Installing PHP-FPM 8.1 on debian server

hi, i have myvestacp installed over debian server last year. right now, i have following web templates: PHP-FPM-73 PHP-FPM-74 PHP-FPM-80 *attached screenshot Screenshot 2022-03-29 200544.jpg i like to install the new web template: PHP-FPM-81 can you please share the instructions regarding the same. ...
by sparkzara
Thu Dec 23, 2021 6:53 pm
Forum: nginx templates
Topic: How to install rate-limit nginx templates
Replies: 10
Views: 9604

Re: How to install rate-limit nginx templates

Thank you for the suggestion. if block idea should help resolve it now. Thank you for the quick reply. static files are not limited in anyway (good to know this) - i didn't realize that earlier. just checked once again and found issue with another plugin on site. regarding whitelist ip , need to set...
by sparkzara
Mon Dec 20, 2021 8:18 pm
Forum: nginx templates
Topic: How to install rate-limit nginx templates
Replies: 10
Views: 9604

Re: How to install rate-limit nginx templates

Thank you for the quick reply. static files are not limited in anyway (good to know this) - i didn't realize that earlier. just checked once again and found issue with another plugin on site. regarding whitelist ip , need to set something, so it doesn't limit apache/php served pages for specific use...
by sparkzara
Mon Dec 20, 2021 7:28 pm
Forum: nginx templates
Topic: How to install rate-limit nginx templates
Replies: 10
Views: 9604

Re: How to install rate-limit nginx templates

hi,
when i add this rate limit template,
my cdn images are getting lot of denied errors.

so how do i whitelist cdn ip address, so they wont be under rate limit ?
by sparkzara
Sat Nov 20, 2021 5:32 pm
Forum: Bash
Topic: Automatic WordPress installing (v-install-wordpress)
Replies: 2
Views: 4736

Re: Automatic WordPress installing (v-install-wordpress)

can we install wordpress on a folder using this script ?
by sparkzara
Mon Nov 08, 2021 6:42 am
Forum: General discussion
Topic: email not sending [vestacp to myvestacp]
Replies: 2
Views: 879

Re: email not sending [vestacp to myvestacp]

thanks for the reply.
i saw the log shows lot of yahoo dns timeout error (i was sending few emails to new server from my yahoo id).
then contacted host regarding the same.
they made fix on hosting side.
now it works fine.