Failed to start The PHP 8.0 FastCGI Process Manager

Post Reply
tienloc1
Posts: 23
Joined: Sun Aug 08, 2021 9:58 pm

I tried to used this cmd:

Code: Select all

v-move-domain-and-database-to-account DOMAIN USER
My website moved successfully but the PHP8 is unable to enable again.

Code: Select all

● php8.0-fpm.service - The PHP 8.0 FastCGI Process Manager
   Loaded: loaded (/lib/systemd/system/php8.0-fpm.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Mon 2022-09-05 03:35:01 +07; 1min 26s ago
     Docs: man:php-fpm8.0(8)
  Process: 3503 ExecStart=/usr/sbin/php-fpm8.0 --nodaemonize --fpm-config /etc/php/8.0/fpm/php-fpm.c
  Process: 3504 ExecStopPost=/usr/lib/php/php-fpm-socket-helper remove /run/php/php-fpm.sock /etc/ph
 Main PID: 3503 (code=exited, status=78)

Sep 05 03:35:00 xxx.xx systemd[1]: Starting The PHP 8.0 FastCGI Process Manager...
Sep 05 03:35:01 xxx.xx php-fpm8.0[3503]: [05-Sep-2022 03:35:01] ERROR: [pool shoptimizer.tienlo
Sep 05 03:35:01 xxx.xx php-fpm8.0[3503]: [05-Sep-2022 03:35:01] ERROR: FPM initialization faile
Sep 05 03:35:01 xxx.xx systemd[1]: php8.0-fpm.service: Main process exited, code=exited, status
Sep 05 03:35:01 xxx.xx systemd[1]: php8.0-fpm.service: Failed with result 'exit-code'.
Sep 05 03:35:01 xxx.xx systemd[1]: Failed to start The PHP 8.0 FastCGI Process Manager.
I'm also trying to enable PHP8.1, it's running but there's no option to choose it from the web template, is it an issue on my own server?
tienloc1
Posts: 23
Joined: Sun Aug 08, 2021 9:58 pm

I tried to remove some conf file in: /etc/php/8.0/fpm/pool.d and it's able to enable now.

But I'm not sure how to get the PHP-FPM-81 in Web Template APACHE2.
Post Reply