Multiple IPs under the same myVesta system?

Post Reply
bfcrew
Posts: 24
Joined: Mon Jun 22, 2020 3:41 pm
Been thanked: 2 times

Hello,

I've discovered that it's feasible to associate multiple IPs and domains in Myvesta. However, I'm encountering challenges in correctly configuring the mail to align with the desired IP and domain.

My goal is to maintain the primary domain but set up subdomains, assigning each subdomain its unique IP. For instance:

server.example.com > [email protected] > IP 1
john.example.com > [email protected] > IP 2
mike.example.com > [email protected] > IP 3
I've successfully set up RDNS and the necessary records, and everything seemed in order. However, when I attempt to send an email from my application using settings like:

hostname: john.example.com
user: [email protected]
port: 2525

The email headers indicate the sender's IP as IP 1, whereas it should be IP 2. This discrepancy persists even with correctly configured SPF, DKIM, and RDNS. I suspect that the exim configuration might be the key to routing mail through the appropriate IP. Does anyone have insights or suggestions on how to address this?
User avatar
isscbta
Team Member
Posts: 132
Joined: Mon Jul 19, 2021 1:41 am
Has thanked: 16 times
Been thanked: 3 times

Take a look at this - viewtopic.php?f=16&t=90
bfcrew
Posts: 24
Joined: Mon Jun 22, 2020 3:41 pm
Been thanked: 2 times

isscbta wrote: Sat Sep 23, 2023 9:47 pm Take a look at this - viewtopic.php?f=16&t=90
I tried the command and it seemed to work. But when I test it by sending an email, the original IP still shows up in the email headers.

Steps I took:

1. Added a new IP to Linode.
2. Set up an A record for the new IP.
3. Set up RDNS.
4. Added the new IP to SPF.
5. Ran a command to configure the IP for my domain.
6. Checked in myVesta, and everything looked good.
7. Checked another command, and it showed the correct domains and IPs.

But when I send a test email from the new subdomain, the original IP still shows.

My setup:

- Using myVesta on Linode with Debian 11.
- Original setup details:
- Hostname: server.mydomain.com (original IP)
- Domain: mydomain.com (original IP)
- Email: [email protected]
- Port: 25

After using your command, I tried sending an email after adding new A record, SPF and RDNS with the following:

- Hostname: james.mydomain.com
- User & Email: [email protected]
- Port: 25

But the test email still shows the original IP. So, I'm using the same domain but a different subdomain.
Post Reply