webmail unsupported php version

Post Reply
User avatar
webxtek
Posts: 37
Joined: Wed Nov 18, 2020 7:43 pm

Hi,
Fresh debian 11 install, i keept php 7.4 installed on sub.hostname.com because it wasnt working properly with phpmyadmin and webmail on other versions.
Then i tried to set php 8.1 only for the normal domain of the host, yourdomain.com... and this error appears when i try to access the webmail:

Unsupported PHP version. Required PHP >= 5.4 and < 8.0. You might need to manually install the phpX.Y package (for X.Y < 8.0) as well as phpX.Y-{cli,intl,json,mbstring}.

i already tried this: viewtopic.php?f=7&t=37 without any success...

if i change php back to 7.4 on that domain it appears this error :

CONFIGURATION ERROR
config.inc.php was not found.
Please read the INSTALL instructions!

Basically i can only access the webmail using the host subdomain
User avatar
myVesta
Site Admin
Posts: 743
Joined: Fri Jun 19, 2020 9:59 am

You should have subdomain only for hostname - and there should be PHP 7.4

To fix Configuration error - see viewtopic.php?f=7&t=37
User avatar
webxtek
Posts: 37
Joined: Wed Nov 18, 2020 7:43 pm

myVesta wrote: Fri Sep 23, 2022 11:09 am You should have subdomain only for hostname - and there should be PHP 7.4

To fix Configuration error - see viewtopic.php?f=7&t=37
Thanks for your quick reply.
Is there any issues if i leave the clients domains that use php 8 and 8.1 looking like this on /webmail and /phpmyadmin ?
Can i just leave them like this?
1.png
1.png (13.75 KiB) Viewed 27 times
2.png
2.png (56.09 KiB) Viewed 27 times
User avatar
myVesta
Site Admin
Posts: 743
Joined: Fri Jun 19, 2020 9:59 am

You can leave it - and tell them to use https://yourhostname/webmail/ and https://yourhostname/phpmyadmin/
User avatar
webxtek
Posts: 37
Joined: Wed Nov 18, 2020 7:43 pm

myVesta wrote: Fri Sep 23, 2022 11:56 am You can leave it - and tell them to use https://yourhostname/webmail/ and https://yourhostname/phpmyadmin/
Perfect, thank you alot!
Post Reply