How to install multi PHP versions

User avatar
myVesta
Site Admin
Posts: 908
Joined: Fri Jun 19, 2020 9:59 am
Has thanked: 8 times
Been thanked: 6 times

compiz wrote: Sun Dec 12, 2021 9:00 pm so we just inst_81=1 ?
Right now you can do it.
I finished the installer before a minute.

Tags:
compiz
Posts: 33
Joined: Fri May 28, 2021 12:29 pm

I was quick!
Meister
Posts: 38
Joined: Mon Nov 08, 2021 10:04 am

in # echo "parameters=$#" is missing "echo "echo "inst_81=$inst_81" :D

but I suspect that it is not important.
User avatar
myVesta
Site Admin
Posts: 908
Joined: Fri Jun 19, 2020 9:59 am
Has thanked: 8 times
Been thanked: 6 times

Meister wrote: Mon Dec 13, 2021 12:53 am in # echo "parameters=$#" is missing "echo "echo "inst_81=$inst_81" :D

but I suspect that it is not important.
nice catch, thank you, fixed :D
yes, that's just informative line.
tienloc1
Posts: 27
Joined: Sun Aug 08, 2021 9:58 pm

No PHP81 in web template apache2, I'm not sure what's wrong with my server.

Image
Image
compiz
Posts: 33
Joined: Fri May 28, 2021 12:29 pm

Have you done the guide as shown above?
tienloc1
Posts: 27
Joined: Sun Aug 08, 2021 9:58 pm

compiz wrote: Mon Sep 05, 2022 8:48 am Have you done the guide as shown above?
Yes, I’ve inst_81=1 and run the script to get the 8.1 installed in myvestacp, but the PHP8.1 doesn't available in the web template and I'm not sure why.
tienloc1
Posts: 27
Joined: Sun Aug 08, 2021 9:58 pm

I'm really needed to install the PHP 8.1 to check my website if it's work well with PHP8.1 or not and it's impossible to display the PHP8.1 in the web template :(, quite stress for me. Already gone through all steps to install it.

EDIT ===================

Ohhh, I just tried to update my file: vesta-inst-php.sh with the one on github and it's work well now, many thank for the link: https://github.com/myvesta/vesta/blob/3 ... install.sh
siyahcop
Posts: 4
Joined: Sun Jan 24, 2021 1:46 pm

Hello.

Php 8.2 is released.
Any change to update the script for 8.2 support?

https://www.php.net/ChangeLog-8.php#8.2.0

Thanks
Messiah
Posts: 7
Joined: Fri Nov 12, 2021 8:28 pm

Hello,

Thank you for the nice script! I know few solutions of multi-php for vesta & myvesta, this is probably the easiest. But there is one funny thing.

PHP 8.2 is installed regardless of the choice. Even when I've removed all 8.0 8.1 and 8.2 code lines from this script it was installed along with required 7.0 and 7.4.

I have websites that require PHP 7.0 to work, I have old CMS that require 5.6, I have modern websites tested at 7.2 - 7.4 so the aim is the minimization of RAM consumption e.g. avoid running/installing unnecessary PHP FPM version. ;)

Also, there is one more point that nobody exactly noticed. Sury physically removed all Debian 9 and 8 packages, so every script based on this repository became broken (please check). If so, the community will appreciate any appropriate replacement of sury repository for this OS.
Post Reply