How to install multi PHP versions

User avatar
myVesta
Site Admin
Posts: 935
Joined: Fri Jun 19, 2020 9:59 am
Has thanked: 8 times
Been thanked: 6 times

Support for PHP 8.3 is just added.

Tags:
rain
Posts: 3
Joined: Fri Jan 12, 2024 10:27 am

Hello
using webmin for updating Debian 12 and getting this error.

Installing package(s) with command apt-get -y install php-mcrypt php8.2-mcrypt ..

The following packages have unmet dependencies:
php-mcrypt : Depends: php8.3-mcrypt but it is not installable
E: Unable to correct problems, you have held broken packages.

This is a new installation of myvestacp 2 days old, installed with multiple PHP versions of php 7.4, 8.1, 8.2, 8.3. Using this post..
viewtopic.php?f=18&t=52

Tried to update via webmin this morning.
I've seen around a few issues of this around.
Have rebooted Debian and tried to redo the updates but no success, the same msg.
Last edited by rain on Fri Jan 12, 2024 10:44 am, edited 2 times in total.
User avatar
myVesta
Site Admin
Posts: 935
Joined: Fri Jun 19, 2020 9:59 am
Has thanked: 8 times
Been thanked: 6 times

Why are you using Webmin with Myvesta?
mcrypt is a deprecated module; I don't know why Webmin is trying to install it.
User avatar
debirose55
Posts: 1
Joined: Sun May 26, 2024 4:49 am

Will updating to a new PHP version affect existing web templates,download lagu or will it only add new features? Thank you.
User avatar
myVesta
Site Admin
Posts: 935
Joined: Fri Jun 19, 2020 9:59 am
Has thanked: 8 times
Been thanked: 6 times

debirose55 wrote: Sun May 26, 2024 4:54 am Will updating to a new PHP version affect existing web templates,download lagu or will it only add new features? Thank you.
It will NOT affect existing templates and PHP versions; it will only add new ones.
Post Reply