How to install multi PHP versions

shahadatnb
Posts: 1
Joined: Sat Jun 26, 2021 5:42 am

Changing the php version in the Web Template but no effect. all time working last php version

Tags:
User avatar
myVesta
Site Admin
Posts: 756
Joined: Fri Jun 19, 2020 9:59 am

shahadatnb wrote: Sat Jun 26, 2021 12:47 pm Changing the php version in the Web Template but no effect. all time working last php version
Maybe you are doing it in "Packages" section, which is wrong place to do that.
Go to WEB -> yourdomain -> EDIT
User avatar
carival60
Posts: 2
Joined: Tue Oct 05, 2021 11:10 pm
Your location: Caracas, Venezuela
First name and last name: Carlos Rivas

Coming from VestaCP to myVesta. Fresh install on Debian 10. The script works nicely, no issues.

Thanks and keep the good work...
juanluis12
Posts: 2
Joined: Thu Nov 18, 2021 8:23 pm

Hello I want to know how I can put 1 in the version of php that I want to install, I am using putty as a command console and when I try to place the 1 to indicate that it is the version that interests me in multiphp it does not allow me then I know which key I must click to put the 1 through ssh in putty.
User avatar
carival60
Posts: 2
Joined: Tue Oct 05, 2021 11:10 pm
Your location: Caracas, Venezuela
First name and last name: Carlos Rivas

juanluis12 wrote: Thu Nov 18, 2021 8:28 pm Hello I want to know how I can put 1 in the version of php that I want to install, I am using putty as a command console and when I try to place the 1 to indicate that it is the version that interests me in multiphp it does not allow me then I know which key I must click to put the 1 through ssh in putty.
As myvesta explained:

1. Download php-installer:

Code: Select all

wget -nv -O ./vesta-inst-php.sh https://c.myvestacp.com/tools/multi-php-install.sh
2. After installation now you need to edit the script before you run it. Using Vi o Nano editors

Code: Select all

nano ./vesta-inst-php.sh
3. Put 1 in desired PHP version.

Code: Select all

inst_56=0
inst_70=0
inst_71=0
inst_72=0
inst_73=0
inst_74=0
inst_80=0
4. After that, save it, and then run the next script:

Code: Select all

sudo bash ./vesta-inst-php.sh
It's pretty straightfoward...

Hope this can help you...
User avatar
myVesta
Site Admin
Posts: 756
Joined: Fri Jun 19, 2020 9:59 am

I think he never used 'vi'.

@juanluis12
Google is your friend, probably even on YouTube you can find 'how to use linux vi tutorial'
compiz
Posts: 25
Joined: Fri May 28, 2021 12:29 pm

When I do update on my server, i see a lot of php 8.1 packages being installed/updated.
Do we have support for php 8.1? Is it out?
User avatar
myVesta
Site Admin
Posts: 756
Joined: Fri Jun 19, 2020 9:59 am

compiz wrote: Sun Nov 21, 2021 1:14 pm When I do update on my server, i see a lot of php 8.1 packages being installed/updated.
Do we have support for php 8.1? Is it out?
nope, it's still in 'release candidate' phase, but obviously package for 8.1 already exists, so I will add templates soon.
Meister
Posts: 35
Joined: Mon Nov 08, 2021 10:04 am

hello,

now PHP 8.1 is released. When will it be implemented in the templates? :)

best regards
compiz
Posts: 25
Joined: Fri May 28, 2021 12:29 pm

I see:
Changelog:
Version 0.9.8-26-53 [12-Dec-2021]
==================================================
* Support for PHP 8.1
* Function to ensure that pool.d folders are not empty

so we just inst_81=1 ?
Post Reply